Teamprise Knowledge Base

TKB00025 TFS Exception (413)

Last updated 2006-04-21 10:58:12 UTC by Martin Woodward

Symptom

When attempting to connect to your Team Foundation Server you get the following error:-

TFS Exception (413)

The exception may look like this:-

413 Exception in Connection Diagnostics

Or you may see the following dialog from Teamprise Explorer:-

413 Exception in Explorer

Cause

You have not supplied the correct port in your Team Foundation Server connection string.

Team Foundation Server usually runs on port 8080 and Windows Sharepoint Services runs on port 80 on that machine. The most common time when you see this error is because you have not supplied the port in the url to connect to Team Foundation Server (i.e. it should be http://servername:8080)

See the dialog below as an example of passing the connection settings to Teamprise:-

Login Dialog

Workaround

Pass the connection as http://servername:8080

If you are already passing the correct port as part of the URL then please contact support

Products affected:

  • Teamprise Command Line Client
  • Teamprise Explorer
  • Teamprise Plugin for Eclipse

Releases affected:

  • 1.0

Platforms affected:

  • All

Related articles:

Keywords: (413) 413 TFS Exception connection problem